<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width; initial-scale=1.0; maximum-scale=1.0; user-scalable=0;">
<title>One Small Shop, One Extreme HPC Storage Challenge</title>
<link rel="pingback" href="https://www.nextplatform.com/xmlrpc.php">

<!-- This site is optimized with the Yoast SEO plugin v4.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Being at the bleeding edge of computing in the life sciences does not always mean operating at extreme scale. For some shops, advancements in new data-gene"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/" />
<link rel="publisher" href="https://plus.google.com/u/0/114375674694752326401/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="One Small Shop, One Extreme HPC Storage Challenge" />
<meta property="og:description" content="Being at the bleeding edge of computing in the life sciences does not always mean operating at extreme scale. For some shops, advancements in new data-gene" />
<meta property="og:url" content="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/" />
<meta property="og:site_name" content="The Next Platform" />
<meta property="article:publisher" content="https://www.facebook.com/theplatformnet" />
<meta property="article:tag" content="DDN" />
<meta property="article:tag" content="GPFS" />
<meta property="article:tag" content="Lustre" />
<meta property="article:section" content="HPC" />
<meta property="article:published_time" content="2017-02-07T12:57:08-05:00" />
<meta property="article:modified_time" content="2017-02-07T13:00:50-05:00" />
<meta property="og:updated_time" content="2017-02-07T13:00:50-05:00" />
<meta property="og:image" content="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="800" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Being at the bleeding edge of computing in the life sciences does not always mean operating at extreme scale. For some shops, advancements in new data-gene" />
<meta name="twitter:title" content="One Small Shop, One Extreme HPC Storage Challenge" />
<meta name="twitter:site" content="@TheNextPlatform" />
<meta name="twitter:image" content="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs.jpg" />
<meta name="twitter:creator" content="@NicoleHemsoth" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.googletagservices.com' />
<link rel='dns-prefetch' href='//nir.regmedia.co.uk' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Next Platform &raquo; Feed" href="https://www.nextplatform.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Next Platform &raquo; Comments Feed" href="https://www.nextplatform.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Next Platform &raquo; One Small Shop, One Extreme HPC Storage Challenge Comments Feed" href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.nextplatform.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='edd-styles-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/easy-digital-downloads/templates/edd.min.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimp-for-wp-checkbox-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/checkbox.min.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='mailchimp-for-wp-form-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/mailchimp-for-wp-pro/assets/css/form.min.css?ver=2.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='parent-theme-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/themes/koenda/style.css?ver=1476965386' type='text/css' media='all' />
<link rel='stylesheet' id='child-theme-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/themes/the-platform/css/platform.css?ver=1477911483' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<link rel='stylesheet' id='googletwpbFonts-css'  href='//fonts.googleapis.com/css?family=Alike&#038;ver=4.7.2' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	  __gaTracker('create', 'UA-33330076-6', 'auto');
  __gaTracker('set', 'forceSSL', true);
  __gaTracker('require', 'displayfeatures');
  __gaTracker('require', 'linkid', 'linkid.js');
  __gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var edd_scripts = {"ajaxurl":"https:\/\/www.nextplatform.com\/wp-admin\/admin-ajax.php","position_in_cart":"","has_purchase_links":"","already_in_cart_message":"You have already added this item to your cart","empty_cart_message":"Your cart is empty","loading":"Loading","select_option":"Please select an option","is_checkout":"0","default_gateway":"","redirect_to_checkout":"1","checkout_page":"https:\/\/www.nextplatform.com\/checkout\/","permalinks":"1","quantities_enabled":"","taxes_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/easy-digital-downloads/assets/js/edd-ajax.min.js?ver=2.7.3'></script>
<script type='text/javascript' src='https://www.googletagservices.com/tag/js/gpt.js?ver=20160202'></script>
<script type='text/javascript' src='https://nir.regmedia.co.uk/?g=c&#038;g=sa&#038;s=c%2Fplat.all&#038;ver=20160202'></script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/functionality-plugin/js/dfp.js?ver=20161027'></script>
<link rel='https://api.w.org/' href='https://www.nextplatform.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nextplatform.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nextplatform.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.nextplatform.com/?p=33894' />
<link rel="alternate" type="application/json+oembed" href="https://www.nextplatform.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nextplatform.com%2F2017%2F02%2F07%2Fone-small-shop-one-extreme-hpc-storage-challenge%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nextplatform.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nextplatform.com%2F2017%2F02%2F07%2Fone-small-shop-one-extreme-hpc-storage-challenge%2F&#038;format=xml" />
<meta name="generator" content="Easy Digital Downloads v2.7.3" />
<meta name="generator" content="EDD CFM v2.0.10" />
<script type="text/javascript">
	window._zem_rp_post_id = '33894';
	window._zem_rp_thumbnails = true;
	window._zem_rp_post_title = 'One+Small+Shop%2C+One+Extreme+HPC+Storage+Challenge';
	window._zem_rp_post_tags = ['lustre', 'ddn', 'gpfs', 'hpc', 'store', 'life', 'scienc', 'code', 'architectur', 'agil', 'van', 'shop', 'world', 'hpc', 'gear', 'zachari', 'storag', 'institut', 'genom', 'comput'];
	window._zem_rp_static_base_url = 'https://content.zemanta.com/static/';
	window._zem_rp_wp_ajax_url = 'https://www.nextplatform.com/wp-admin/admin-ajax.php';
	window._zem_rp_plugin_version = '1.14';
	window._zem_rp_num_rel_posts = '6';
</script>
<link rel="stylesheet" href="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/related-posts-by-zemanta/static/themes/vertical.css?version=1.14" />
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/The-Next-Platform-Final-Cubes1.png" type="image/x-icon" />
<!-- Custom Styling -->
<style type="text/css">
.micro-site-rambus #searchform{
 display: none;
}

.micro-site-rambus .micro-site-logo {
    margin: 0 0px 0px 0px;
}

.micro-site-rambus .menuwrapp {
    margin-top: -2px;
}
</style>
<link rel="amphtml" href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/amp/" /><script>init_gpt('hpc,store', 'DDN,GPFS,Lustre');</script><style type="text/css">.mc4wp-form input[name="_mc4wp_required_but_not_really"] { position: absolute; top: -1000000px; }</style><link rel="icon" href="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/cropped-PlatformStack-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/cropped-PlatformStack-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/cropped-PlatformStack-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/cropped-PlatformStack-270x270.jpg" />

</head>
<body class="post-template-default single single-post postid-33894 single-format-standard custom-background cat-hpc cat-store">
	<div id="wrapper">
		<div id="header">
		   <div class="topbar">
			<ul id="menu-verytop" class="topbarnav"><li id="menu-item-123" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-123"><a href="https://www.nextplatform.com/about/">About</a></li>
<li id="menu-item-161" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-161"><a href="https://www.nextplatform.com/contributors/">Contributors</a></li>
<li id="menu-item-125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-125"><a href="https://www.nextplatform.com/contact/">Contact</a></li>
<li id="menu-item-121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-121"><a href="http://www.theregister.co.uk">The Register</a></li>
</ul>			</div> <!--  END topbar  -->

                			<div id=adunit_a class=ad>
    			<script>show_gpt('adunit_a');</script>
    			</script>
    			</div>
    			<div id=adunit_b class=ad>
    			<script>show_gpt('adunit_b');</script>
    			</div>
            
			               <a class="logo" href="https://www.nextplatform.com/"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/The-Next-Platform-Final.png" /></a>
									<div class="menuwrapp">
							<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-11" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11"><a href="https://www.nextplatform.com/">Home</a></li>
<li id="menu-item-52" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52"><a href="https://www.nextplatform.com/category/compute/">Compute</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55"><a href="https://www.nextplatform.com/category/store/">Store</a></li>
<li id="menu-item-53" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53"><a href="https://www.nextplatform.com/category/connect/">Connect</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.nextplatform.com/category/control/">Control</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://www.nextplatform.com/category/code/">Code</a></li>
<li id="menu-item-77" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://www.nextplatform.com/category/analyze/">Analyze</a></li>
<li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62"><a href="https://www.nextplatform.com/category/hpc/">HPC</a></li>
<li id="menu-item-61" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61"><a href="https://www.nextplatform.com/category/enterprise/">Enterprise</a></li>
<li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="https://www.nextplatform.com/category/hyperscale/">Hyperscale</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.nextplatform.com/category/cloud/">Cloud</a></li>
<li id="menu-item-3949" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3949"><a href="https://www.nextplatform.com/2016-titles-next-platform-press/">Books</a></li>
<li id="menu-item-5497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5497"><a href="https://www.nextplatform.com/category/sc16/">SC16</a></li>
</ul></div>						</div> <!--  END menuwrapp  -->
			<div class="menuwrapp_mobile">
					 <a class="mobilemenu_toggle" href="#" >Menu</a>
											<div class="menu-main-container"><ul id="menu-main-1" class="menu_mobile"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-11"><a href="https://www.nextplatform.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52"><a href="https://www.nextplatform.com/category/compute/">Compute</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-55"><a href="https://www.nextplatform.com/category/store/">Store</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53"><a href="https://www.nextplatform.com/category/connect/">Connect</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.nextplatform.com/category/control/">Control</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://www.nextplatform.com/category/code/">Code</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77"><a href="https://www.nextplatform.com/category/analyze/">Analyze</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-62"><a href="https://www.nextplatform.com/category/hpc/">HPC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61"><a href="https://www.nextplatform.com/category/enterprise/">Enterprise</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="https://www.nextplatform.com/category/hyperscale/">Hyperscale</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.nextplatform.com/category/cloud/">Cloud</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3949"><a href="https://www.nextplatform.com/2016-titles-next-platform-press/">Books</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5497"><a href="https://www.nextplatform.com/category/sc16/">SC16</a></li>
</ul></div>								</div> <!--  END menuwrapp  -->
		</div> <!--  END header  -->
		<div id="content">
			<div class="clearfix right_sidebar">
			    				<div class="pagecontent">
		        					<ul class="posts fullwidth singlepost">
											<li id="post-33894" class="post-33894 post type-post status-publish format-standard has-post-thumbnail hentry category-hpc category-store tag-ddn tag-gpfs tag-lustre">
							<article class="short">
								<h1>One Small Shop, One Extreme HPC Storage Challenge</h1>
								<p class="posted">
									<span class="date_time">February 7, 2017</span>
																			<span class="postedby">
																															<a href="https://www.nextplatform.com/author/nicole/" title="Posts by Nicole Hemsoth" rel="author">Nicole Hemsoth</a>																				</span>
																	</p>
								<img width="200" height="200" src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs-200x200.jpg" class="feat-img wp-post-image" alt="" srcset="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs-200x200.jpg 200w, https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs-150x150.jpg 150w, https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs-300x300.jpg 300w, https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/06/dna_stairs.jpg 800w" sizes="(max-width: 200px) 100vw, 200px" />								<p><p>Being at the bleeding edge of computing in the life sciences does not always mean operating at extreme scale. For some shops, advancements in new data-generating scientific tools requires forward thinking at the infrastructure level—even if it doesn’t require a massive cluster with exotic architectures. We tend to cover much of what happens at the extreme scale of computing here, but it’s worth stepping back and observing how dramatic problems in HPC are addressed in much smaller environments.</p>
<p>This “small shop, big problem” situation is familiar to the Van Andel Research Institute (VARI), which recently moved from a genomics and molecular dynamics focus into the world of ultra-high resolutions cryo-electron microscopy. The center acquired one of the most powerful Cryo-EM microscopes in the world and as a result, was pushed into thinking big about hardware (storage in particular) within a relatively small cluster environment.</p>
<p>To better understand the intricacies of planning a high performance computing environment around such a powerful data-generating microscope, we talked with the institute’s Zachary Ramjan, who says that for the research teams using his gear value very high performance as well as the agility to quickly adopt new codes and tools from a largely open-source community base. To this end, he has architected VARI’s environment around these requirements, which includes the need to store and manage 13 petabytes of data daily from the 2,000+ core clustered compute, equipped with some GPU nodes (interestingly, the team had Nvidia Tesla K80s but found better performance for their workloads using the workstation graphics-focused GTX 1080s, which are Pascal at the core but at less than one quarter of the cost).</p>
<p>Ramjan was initially tasked with building a high performance computing environment for VARI that was focused on genomics and molecular dynamics, but with the addition of the Cry-EM, he said they had to take a fresh look at scalable storage. The center had been an Isilon shop in earlier days, but he says the pricing was far higher, which pushed him to look at both GPFS (now called IBM Spectrum Scale) and Lustre—the two leading high performance file systems. He says that while Lustre had some benefits, the number of people required to manage it was going to be far too high. Further, he felt locked into disk geometries with the Lustre implementation he surveyed and with growing data requirements, being stuck buying out of date spinning disk to fit the same geometries was not an option. While the team did not opt to buy SSDs, it did select GPFS delivered via a DDN GS7K parallel file system as well as the company’s WOS object storage to match the private cloud delivery model Ramjan wants to solidify internally for his users.</p>
<blockquote><p>“We went with GPFS because it was more robust in terms of functionally and required far less manpower. Initially we didn’t have tiers, but with Cryo-EM we wanted to have a multi-tiered solution. GPFS looked cleaner and easier here and there are protocol nodes as part of the product, which meant we could also do NFS, Ceph, and object all under the same project.”</p></blockquote>
<p>The storage environment when the shop was devoted to genomics and molecular dynamics was very siloed, Ramjan explains. “We had chunks of storage everywhere, which wasn’t economical or manageable or high performance. When I came in, we took the HPC approach of getting a big chunk of high performance storage that could be easily scaled out and added to incrementally, but then we went about bought this massive Cryo-EM microscopy technology and all of a sudden the storage projections were way off—we needed to increase 60% in size immediately.” He says the took a tier approach since not everything needed to be in ultra-fast storage and with the WOS object storage, which is policy-driven so the cold data could sit on the cheaper, dense storage, the team was able to adapt to the demands of the new microscope.</p>
<p>Even though Ramjan’s users are more focused on their research than wrapping around a new approach to getting their results, he says the investments made in OpenStack and preparing for a more object-oriented world will eventually pay off. Currently, users at the center can access compute through the traditional PBS batch processing environment or via the OpenStack private cloud. “A lot of their work is open source and many of those tools only run in an old school cluster environment. But a lot of the new stuff that might not be mainstream in the scientific community yet will look more like Spark-based processing versus MPI. As those tools become more popular and fit into a cloud model—an object model versus cluster one—we’ll be ready to go infrastructure wise if they’ll adopt it.</p>
<p>Even though OpenStack is available for researchers at VARI, Ramjan says it will take time before they begin using in greater numbers. They are very sensitive to the performance of their applications, and he says despite what he has read, the virtualization overhead is not insignificant. “When you’re at the fringes of computing with maximum CPU, RAM, and I/O these problems with overheads really show up. At the extremes, I think there’s a higher penalty in terms of overhead.”</p>
<blockquote><p>“Deploying an end-to-end storage solution has allowed us to elevate the standard of protection, increase compliance and push the boundaries of science on a single, highly scalable storage platform. We’ve also saved hundreds of thousands of dollars by centralizing the storage of our data-intensive research and a dozen data-hungry scientific instruments on DDN. With all these advantages it is easy to see why DDN is core to our operation and a major asset to our scientists.”</p></blockquote>
<p>While VARI’s environment is facing many of the same challenges other HPC centers have in terms of performance for demanding applications, they are not operating at the same scale in terms of node counts or novel approaches. However, their journey through infrastrchucture requirements to meet the needs of data-generating tools is representative of that of other organizations in life sciences and beyond. At the base, Ramjan says, is having the ability to be agile—to add new resources quickly. At the base of that stack is storage, which if VARI is indication, can provide a backbone to keep building and scaling up and out.</p>
<div class="sharedaddy sd-sharing-enabled">
<div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing">
<h3 class="sd-title">Share this:</h3>
<div class="sd-content">
<ul>
<li class="share-reddit"><a href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=reddit" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=reddit', 'Reddit');" rel="nofollow" data-shared="" class="share-reddit sd-button share-icon"  target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li>
<li class="share-facebook"><a href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=facebook" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=facebook', 'Facebook');" rel="nofollow" data-shared="sharing-facebook-33894" class="share-facebook sd-button share-icon"  target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li>
<li class="share-linkedin"><a href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=linkedin" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=linkedin', 'LinkedIn');" rel="nofollow" data-shared="sharing-linkedin-33894" class="share-linkedin sd-button share-icon"  target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li>
<li class="share-twitter"><a href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=twitter" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=twitter', 'Twitter');" rel="nofollow" data-shared="sharing-twitter-33894" class="share-twitter sd-button share-icon"  target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li>
<li class="share-google-plus-1"><a href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=google-plus-1" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=google-plus-1', 'Google');" rel="nofollow" data-shared="sharing-google-33894" class="share-google-plus-1 sd-button share-icon"  target="_blank" title="Click to share on Google+"><span>Google</span></a></li>
<li class="share-email"><a href="https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=email" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.nextplatform.com/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/?share=email', 'Email');" rel="nofollow" data-shared="" class="share-email sd-button share-icon"  target="_blank" title="Click to email this to a friend"><span>Email</span></a></li>
<li class="share-end"></li>
</ul>
</div>
</div>
</div>

<div class="zem_rp_wrap zem_rp_th_vertical" id="zem_rp_first"><div class="zem_rp_content"><h3 class="related_post_title">Similar Vein</h3><ul class="related_post zem_rp"><li data-position="0" data-poid="in-251" data-post-type="none"><a href="https://www.nextplatform.com/2015/03/03/what-stands-in-the-way-of-enterprise-lustre-adoption/" class="zem_rp_thumbnail"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/03/wall-150x150.jpg" alt="What Stands in the Way of Enterprise Lustre Adoption?" width="150" height="150"  /></a><a href="https://www.nextplatform.com/2015/03/03/what-stands-in-the-way-of-enterprise-lustre-adoption/" class="zem_rp_title">What Stands in the Way of Enterprise Lustre Adoption?</a></li><li data-position="1" data-poid="in-6176" data-post-type="none"><a href="https://www.nextplatform.com/2016/11/08/ddn-turns-crank-wolfcreek-storage/" class="zem_rp_thumbnail"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/11/ddn-wolfcreek-logo-bw-150x150.jpg" alt="DDN Turns The Crank On &#8220;Wolfcreek&#8221; Storage" width="150" height="150"  /></a><a href="https://www.nextplatform.com/2016/11/08/ddn-turns-crank-wolfcreek-storage/" class="zem_rp_title">DDN Turns The Crank On &#8220;Wolfcreek&#8221; Storage</a></li><li data-position="2" data-poid="in-2666" data-post-type="none"><a href="https://www.nextplatform.com/2016/02/24/arm-open-source-feed-buzz-around-hpc-file-system/" class="zem_rp_thumbnail"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/08/disk-racks-150x150.jpg" alt="ARM, Open Source Feed Buzz Around HPC File System" width="150" height="150"  /></a><a href="https://www.nextplatform.com/2016/02/24/arm-open-source-feed-buzz-around-hpc-file-system/" class="zem_rp_title">ARM, Open Source Feed Buzz Around HPC File System</a></li><li data-position="3" data-poid="in-1550" data-post-type="none"><a href="https://www.nextplatform.com/2015/08/14/panasas-expands-reach-beyond-hpc-foundations/" class="zem_rp_thumbnail"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/08/disk-racks-150x150.jpg" alt="Panasas Expands Reach Beyond HPC Foundations" width="150" height="150"  /></a><a href="https://www.nextplatform.com/2015/08/14/panasas-expands-reach-beyond-hpc-foundations/" class="zem_rp_title">Panasas Expands Reach Beyond HPC Foundations</a></li><li data-position="4" data-poid="in-330" data-post-type="none"><a href="https://www.nextplatform.com/2015/03/09/where-is-lustre-finding-its-brightest-shine/" class="zem_rp_thumbnail"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/03/ab145-150x150.jpg" alt="Where is Lustre Finding its Brightest Shine?" width="150" height="150"  /></a><a href="https://www.nextplatform.com/2015/03/09/where-is-lustre-finding-its-brightest-shine/" class="zem_rp_title">Where is Lustre Finding its Brightest Shine?</a></li><li data-position="5" data-poid="in-231" data-post-type="none"><a href="https://www.nextplatform.com/2015/03/02/tracing-the-enterprise-path-for-lustre/" class="zem_rp_thumbnail"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/03/path2-150x150.jpg" alt="Tracing the Enterprise Path for Lustre" width="150" height="150"  /></a><a href="https://www.nextplatform.com/2015/03/02/tracing-the-enterprise-path-for-lustre/" class="zem_rp_title">Tracing the Enterprise Path for Lustre</a></li></ul></div></div>
</p>
								<p class="meta_tags">Categories: <a href="https://www.nextplatform.com/category/hpc/" rel="category tag">HPC</a>, <a href="https://www.nextplatform.com/category/store/" rel="category tag">Store</a></p>
								<p class="meta_tags">Tags: <a href="https://www.nextplatform.com/tag/ddn/" rel="tag">DDN</a>, <a href="https://www.nextplatform.com/tag/gpfs/" rel="tag">GPFS</a>, <a href="https://www.nextplatform.com/tag/lustre/" rel="tag">Lustre</a></p>
															</article>
							<p></p>
							<p class="pagination">
								<span class="prev"><a href="https://www.nextplatform.com/2017/02/07/new-twist-adding-data-persistence-containers/" rel="prev">A New Twist On Adding Data Persistence To Containers</a></span>
								<span class="next"><a href="https://www.nextplatform.com/2017/02/07/supercomputing-agenda-marks-rise-china-real-world-benchmarks/" rel="next">Rise of China, Real-World Benchmarks Top Supercomputing Agenda</a></span>
							</p>
							<div id="comments">
								<div class="comments">
			<p></p>
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.nextplatform.com/wp-comments-post.php?wpe-comment-post=tpmn" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='33894' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7584c72bc6" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="216"/></p>			</form>
			</div><!-- #respond -->
	</div>
							</div>
						</li>
										</ul>
									</div> <!--  END Page  -->
				<div class="sidebar">
    <div class="widget"><form role="search" method="get" id="searchform" class="searchform" action="https://www.nextplatform.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div class="widget">			<div class="textwidget"><div id="plat-social-widget"><a href="https://www.nextplatform.com/feed/" target="_blank" title="Check Our Feed"></a><a href="http://www.twitter.com/TheNextPlatform" target="_blank" title="Visit Us On Twitter"></a><a href="https://www.facebook.com/theplatformnet" target="_blank" title="Visit Us On Facebook"></a><a href="https://www.linkedin.com/company/the-platform-magazine-" target="_blank" title="Visit Us On Linkedin"></a><a href="https://plus.google.com/u/0/114375674694752326401/posts" target="_blank" title="Visit Us On GooglePlus"></a><a href="mailto:nicole@theplatform.net" title="Email the editor"></a></div></div>
		</div><div class="widget">			<div class="textwidget"><style>
#rambus {
  width: 300px;
  margin: 0;
  padding: 0;
}
#rambusblog {
  width: 286px;
  border: 1px #CDCDCD solid;
  border-top: 0;
  margin: 0;
  padding: 10px 6px 0 6px;
}
#rambusimg {
  padding: 0;
  margin: 0;
  height: 60px;
}
#rambusblog p {
  padding: 6px 0 3px 0;
  margin: 0;
  font-size: smaller;
}
#rambus a {
  color: #1c57cd;
  text-decoration: none;
}
#rambus a:hover {
  text-decoration: underline;
}
</style>

<div id="rambus">

  <div id="rambusimg">
    <a href="http://pubads.g.doubleclick.net/gampad/clk?id=103323819&iu=/6978"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2016/09/Rambus_NextPlatform_Button.jpeg" width=300 height=60 alt="Rambus" border=0></a>
  </div>

  <div id="rambusblog">

    <p><a href="http://pubads.g.doubleclick.net/gampad/clk?id=116767659&iu=/6978/textlink">How secure IoT endpoints can help mitigate DDoS attacks</a></p>
    <p><a href="http://pubads.g.doubleclick.net/gampad/clk?id=115448619&iu=/6978/textlink">Simplifying SKU management with CryptoManager</a></p>
    <p><a href="http://pubads.g.doubleclick.net/gampad/clk?id=106448259&iu=/6978/textlink">Implementing a secure cardless set-top box</a></p>
  </div>

</div></div>
		</div><div class="widget">			<div class="textwidget"><div id="mellanoxbtn">
<a href="https://www.nextplatform.com/micro-site-content/mellanox/"><img src="https://regmedia.co.uk/2016/09/08/mellanox-300x100-thenextplatform.png" width=300 height=100 alt="Mellanox" /></a></div>
		</div><div class="widget">			<div class="textwidget"><!-- ADUNIT D -->
<div id=adunit_d class=ad style="margin-left:-10px;">
<script>show_gpt('adunit_d');</script>
</div>
</div>
		</div><div class="widget"><h2>The Next Platform Weekly</h2>			<div class="textwidget"><a href="https://www.nextplatform.com/register/"><img src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/uploads/2015/04/The-Next-Platform-Final-Cubes2.png" width="75" height="120" class="alignleft" /></a>Tap the stack to painlessly subscribe for a weekly email from The Next Platform,  featuring highlights, analysis, and stories from the week directly from us to your inbox with nothing in between.</div>
		</div><div class="widget">			<div class="textwidget"><div id=adunit_c class=ad style="margin-left:-10px;">
<script>show_gpt('adunit_c');</script>
</div></div>
		</div><div class="widget">			<div class="textwidget"><div id=adunit_e class=ad>
<script>show_gpt('adunit_e');</script>
</div></div>
		</div></div> 			</div> <!--  END Clearfix  -->
		</div> <!--  END Content  -->
<div id=adunit_f class=ad>
<script>show_gpt('adunit_f');</script>
</div>
<div id="footer" class="clearfix">
			<div class="widget-footer">
											<h3>Pages</h3><div class="menu-pages-container"><ul id="menu-pages" class="menu"><li id="menu-item-452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-452"><a href="https://www.nextplatform.com/about/">About</a></li>
<li id="menu-item-454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-454"><a href="https://www.nextplatform.com/contact/">Contact</a></li>
<li id="menu-item-451" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-451"><a href="https://www.nextplatform.com/contributors/">Contributors</a></li>
<li id="menu-item-453" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-453"><a href="https://www.nextplatform.com/register/">Newsletter</a></li>
</ul></div>								</div>
			<div class="widget-footer">
															<h3>Recent Posts</h3>		<ul>
					<li>
				<a href="https://www.nextplatform.com/2017/02/24/glimmer-light-dark-silicon/">A Glimmer of Light Against Dark Silicon</a>
						</li>
					<li>
				<a href="https://www.nextplatform.com/2017/02/23/promises-challenges-ahead-near-memory-memory-processing/">Promises, Challenges Ahead for Near-Memory, In-Memory Processing</a>
						</li>
					<li>
				<a href="https://www.nextplatform.com/2017/02/23/exascale-leaders-look-next-horizons-supercomputing/">Exascale Leaders on Next Horizons in Supercomputing</a>
						</li>
					<li>
				<a href="https://www.nextplatform.com/2017/02/22/current-trends-tools-large-scale-machine-learning/">Current Trends in Tools for Large-Scale Machine Learning</a>
						</li>
					<li>
				<a href="https://www.nextplatform.com/2017/02/22/google-spanner-inspires-cockroachdb-outrun/">Google Spanner Inspires CockroachDB To Outrun It</a>
						</li>
				</ul>
												</div>
			<div class="widget-footer">
																			</div>
			<div class="widget-footer wflast">
											<form role="search" method="get" id="searchform" class="searchform" action="https://www.nextplatform.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form>								</div>
			<p class="copyright"><span class="ycopy">Copyright © 2017 The Next Platform</span></p>
		</div> <!--  END Footer  -->
	</div> <!--  END Wrapper  -->
		<script type="text/javascript">
		jQuery(document).on("DOMNodeInserted", function(){
			// Lock uploads to "Uploaded to this post"
			jQuery('select.attachment-filters [value="uploaded"]').attr( 'selected', true ).parent().trigger('change');
		});
		</script>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.nextplatform.com\/2017\/02\/07\/one-small-shop-one-extreme-hpc-storage-challenge\/":33894};
	</script>
	<div id="sharing_email" style="display: none;">
		<form action="/2017/02/07/one-small-shop-one-extreme-hpc-storage-challenge/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201708'></script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/themes/koenda/js/main.js?ver=1.0'></script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://3s81si1s5ygj3mzby34dq6qf-wpengine.netdna-ssl.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201708.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'86113652',post:'33894',tz:'-5',srv:'www.nextplatform.com'} ]);
	_stq.push([ 'clickTrackerInit', '86113652', '33894' ]);
</script>
</body>
</html>
